Booking & scheduling

Incident Report for meetergo

Resolved

Appointment booking and scheduling are operating normally again. The disruption was caused by a recent deployment, which we rolled back. No booking data was affected. Apologies for the interruption.
Posted Jun 22, 2026 - 10:54 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 22, 2026 - 10:51 UTC

Identified

We've identified intermittent errors when creating or managing appointments, caused by a recent deployment, and are rolling it back now. Existing bookings and your data are not affected. Next update within 15 minutes.
Posted Jun 22, 2026 - 10:49 UTC

Investigating

We're investigating reports of errors when creating or managing appointments. Existing bookings and data are unaffected. We're actively working on it and will update shortly.
Posted Jun 22, 2026 - 10:48 UTC
This incident affected: API.