Status Update – meetergo Availability

Incident Report for meetergo

Resolved

This incident has been resolved.
Posted Apr 01, 2026 - 09:11 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 01, 2026 - 09:10 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 01, 2026 - 09:09 UTC

Identified

We are currently experiencing a temporary downtime affecting forms and selection pages.

Our team is actively working to resolve the issue as quickly as possible. We will provide an update once full functionality has been restored.

Thank you for your patience and understanding.
Posted Apr 01, 2026 - 08:41 UTC
This incident affected: my.meetergo.com and cal.meetergo.com.